egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Eggdrop stops working and dies

 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help
View previous topic :: View next topic  
Author Message
CP1832
Halfop


Joined: 09 Oct 2014
Posts: 49

PostPosted: Fri Oct 06, 2017 3:22 pm    Post subject: Eggdrop stops working and dies Reply with quote

For a few weeks my bot has been getting stoned every once in a while, like each two days, so I'm using this script to kill the pid when it gets stoned. The script works flawlessly, but I want to know which script could be causing my eggdrop to get stoned. How can I check that? The log file shows absolutely nothing useful. What else could I do? And how (I'm not very Linux savvy)?

Thanks in advance.
Back to top
View user's profile Send private message
caesar
Ass Kicker


Joined: 14 Oct 2001
Posts: 3403
Location: Area 51

PostPosted: Sat Oct 07, 2017 5:25 am    Post subject: Reply with quote

Try without any loaded mods or scripts and then load one by one?
_________________
You may say anything about me, but don't misspell my name.
Back to top
View user's profile Send private message
CP1832
Halfop


Joined: 09 Oct 2014
Posts: 49

PostPosted: Mon Oct 09, 2017 10:32 am    Post subject: Reply with quote

That crossed my mind, but I have some 30 scripts loaded and they worked fine until recently (haven't modified them in a long while), so I have no clues where to start. Is there any debugging tool available for this kind of issues?
Back to top
View user's profile Send private message
willyw
Owner


Joined: 15 Jan 2009
Posts: 923

PostPosted: Mon Oct 09, 2017 11:02 am    Post subject: Reply with quote

CP1832 wrote:

... but I have some 30 scripts loaded and they worked fine until recently


But in your first post, you indicated that you felt that the problem IS a script.

Quote:

(haven't modified them in a long while), so I have no clues where to start. Is there any debugging tool available for this kind of issues?


How about if it isn't a script at all? That much, you could find out within a couple days. Simply unload ALL scripts. Be sure they are unloaded. All of them. Then let bot run for a couple days. If it happens again, you know it is not a script.

I'm saying this, because you seem to be saying that you have changed nothing, yet this behavior started. So something changed. If not you and your bot, then what's left? The shell it is on - could the admin there have changed something? And... the irc server that your bot connects to.... could the admin there have changed something?

I'm just kicking around ideas....
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
CP1832
Halfop


Joined: 09 Oct 2014
Posts: 49

PostPosted: Mon Oct 09, 2017 11:17 am    Post subject: Reply with quote

I thought the problem had to be a script, it was my first guess. As you mentioned, many other things can be causing this. I'll unload all the scripts and give it a shot.
Back to top
View user's profile Send private message
willyw
Owner


Joined: 15 Jan 2009
Posts: 923

PostPosted: Mon Oct 09, 2017 3:33 pm    Post subject: Reply with quote

Good.
I assume that in a couple days you'll be letting us know what you discovered. It will be info that is one more piece to your puzzle.

If it stops, and thus you feel more assured that it is IS a script, then I'm with caesar - load them back, one at a time, until you find the one that is causing it. Sorry, but without something logged or appearing in the partyline, I don't know a better method. If anybody else does, perhaps they will speak up now.

Note - neither your nor I mentioned loaded modules. Caesar did though.

If it continues, with no scripts loaded - ... I'm not sure how to proceed then.
Maybe somebody else will be along by then, to help you deal with that new info.

Let us know how it goes.
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
caesar
Ass Kicker


Joined: 14 Oct 2001
Posts: 3403
Location: Area 51

PostPosted: Tue Oct 10, 2017 12:59 am    Post subject: Reply with quote

30 scripts? Oh my!

Sadly there's no easy way to figure out the culprit, so you are stuck with unloading all the scripts and modules (if added any special ones) and see if there's any improvements. Do you have a high CPU / RAM usage?
_________________
You may say anything about me, but don't misspell my name.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber