egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

SayWeather : Support & Updates
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Support & Releases
View previous topic :: View next topic  
Author Message
JJTX
Voice


Joined: 05 May 2015
Posts: 10
Location: United States

PostPosted: Sun Feb 10, 2019 5:56 pm    Post subject: Reply with quote

I got the API and put it in quotes.

Set my default

But the script never responds to me when I do !w zip or location...

It responds when I do !w -see
Back to top
View user's profile Send private message
roger
Halfop


Joined: 17 Jun 2018
Posts: 53

PostPosted: Sun Feb 10, 2019 7:38 pm    Post subject: hi Reply with quote

where did you get your key from?

also did you do a .chanset #channel +weather ?


Last edited by roger on Sun Feb 10, 2019 7:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
JJTX
Voice


Joined: 05 May 2015
Posts: 10
Location: United States

PostPosted: Sun Feb 10, 2019 7:39 pm    Post subject: Re: hi Reply with quote

roger wrote:
where did you get your key from?


https://www.apixu.com
Back to top
View user's profile Send private message
roger
Halfop


Joined: 17 Jun 2018
Posts: 53

PostPosted: Sun Feb 10, 2019 7:44 pm    Post subject: weather Reply with quote

Set my default ?
Back to top
View user's profile Send private message
JJTX
Voice


Joined: 05 May 2015
Posts: 10
Location: United States

PostPosted: Sun Feb 10, 2019 8:02 pm    Post subject: Re: weather Reply with quote

roger wrote:
Set my default ?


Yes I set it......


and its acknowledged


And if I give it a bogus airport code it will say NOT FOUND .

Does the script output a log file ?
Back to top
View user's profile Send private message
JJTX
Voice


Joined: 05 May 2015
Posts: 10
Location: United States

PostPosted: Mon Feb 11, 2019 7:39 am    Post subject: Reply with quote

The problem is on my end. I'm using a free shell from my hosting service and in these shells they dont allow server processes.
_________________
irc.usairc.org +6697
Back to top
View user's profile Send private message
roger
Halfop


Joined: 17 Jun 2018
Posts: 53

PostPosted: Mon Feb 11, 2019 11:15 am    Post subject: that sucks Reply with quote

Crying or Very sad
Back to top
View user's profile Send private message
JJTX
Voice


Joined: 05 May 2015
Posts: 10
Location: United States

PostPosted: Mon Feb 11, 2019 9:52 pm    Post subject: Re: that sucks Reply with quote

roger wrote:
Crying or Very sad


Thanks for trying though. When I grab a paid one, I'll try again.
_________________
irc.usairc.org +6697
Back to top
View user's profile Send private message
spuniun
Voice


Joined: 12 Oct 2005
Posts: 10

PostPosted: Mon Apr 08, 2019 12:19 pm    Post subject: Reply with quote

I've installed the script and edited nothing other than API key and +weather on channel but I have the following binds which look invalid and bot does nothing for !w or any other cmd:
Code:
Command bindings:
  TYPE FLAGS    COMMAND              HITS BINDING (TCL)
  pubm -|-      ?%~\.*                  0 ::saywz::say_w
  pubm -|-      ?%~\!*                  0 ::saywz::say_w

eggy is eggdrop v1.8.4+base on ubuntu 16.04 with tcl8.6 (I assume this is backward compatible?)
Back to top
View user's profile Send private message
willyw
Revered One


Joined: 15 Jan 2009
Posts: 1046

PostPosted: Mon Apr 08, 2019 1:36 pm    Post subject: Reply with quote

spuniun wrote:
I've installed the script and edited nothing other than API key and +weather on channel but I have the following binds which look invalid and bot does nothing for !w or any other cmd:
Code:
Command bindings:
  TYPE FLAGS    COMMAND              HITS BINDING (TCL)
  pubm -|-      ?%~\.*                  0 ::saywz::say_w
  pubm -|-      ?%~\!*                  0 ::saywz::say_w

eggy is eggdrop v1.8.4+base on ubuntu 16.04 with tcl8.6 (I assume this is backward compatible?)


Those are valid. It's how he wrote the script.

But notice the hit counter? Zero.
Test that some more, please. Because if those hit counters do not increment with every use of command, then something is wacky.

Just to compare, this is from one of mine:

Code:

<mynick> .binds *say*
<bot> [13:37:40] #mynick# binds *say*
<bot> Command bindings:
<bot>   TYPE FLAGS    COMMAND              HITS BINDING (TCL)
<bot>   pubm -|-      ?%~\.*                 20 ::saywz::say_w
<bot>   pubm -|-      ?%~\!*                 61 ::saywz::say_w
<bot>   time -|-      *                    21614 ::saywz::bindtime


_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
spuniun
Voice


Joined: 12 Oct 2005
Posts: 10

PostPosted: Mon Apr 08, 2019 4:52 pm    Post subject: Reply with quote

willyw wrote:
Those are valid. It's how he wrote the script.
Thanks for the tip. the way it's binding must be conflicting with my channel encryption scripts cause they are not being handed off to script - I'll have to look at that and see if I can figure a work around.
Back to top
View user's profile Send private message
BarGuy
Voice


Joined: 20 Aug 2019
Posts: 8

PostPosted: Thu Oct 10, 2019 4:16 pm    Post subject: Reply with quote

I see apixu is shutting down and switching over to weatherstack.com. I tried editing my sayweather script with my new api key and replacing the apixu input to http://api.weatherstack.com/current?access_key= but I still get Error: No Error and No Location Data?? when trying to trigger weather with my bot. Am I missing something?
Back to top
View user's profile Send private message
Arnold_X-P
Op


Joined: 30 Oct 2006
Posts: 191
Location: DALnet - Trinidad - Beni - Bolivia

PostPosted: Thu Oct 17, 2019 8:12 pm    Post subject: Reply with quote

the tcl worked fine
[12:22] «@Arnold_X-P» !w bolivia
[12:22] «@Kantuta» La Paz, La Paz, Bolivia (-16.5, -68.15): Friday, 04 October 2019 12:23:27

but for a week I see that it no longer works, apparently something was modified or updated on the web:
[02:20] «dddr» !w iquitos
[02:20] «@Kantuta» Error2:
[19:59] «Arnold_X-P» !w japan
[19:59] «@Kantuta» Error: No Error and No Location Data??
_________________
Very Happy thanks to that they help, that others learn Very Happy
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
Ripcord
Voice


Joined: 10 Oct 2019
Posts: 1

PostPosted: Sat Nov 02, 2019 10:35 pm    Post subject: Reply with quote

BarGuy wrote:
I see apixu is shutting down and switching over to weatherstack.com. I tried editing my sayweather script with my new api key and replacing the apixu input to http://api.weatherstack.com/current?access_key= but I still get Error: No Error and No Location Data?? when trying to trigger weather with my bot. Am I missing something?


Yeah, I tried the same thing. The new site has changed the format of the URL. I've been going crazy trying to figure out the new URL but haven't had much luck so far.
Back to top
View user's profile Send private message
spilled
Voice


Joined: 07 Nov 2019
Posts: 1

PostPosted: Thu Nov 07, 2019 10:39 pm    Post subject: Reply with quote

Tried the new site with a new apikey. It's replying just using the key and a query arg. here's the URL I used with an bogus key. got a nice piece of JSON back with just a generic query. i never dumped the previous format so I don't know/suspect that we're dealing with the same shape of data here. I doubt it.


http://api.weatherstack.com/current?access_key=abc123def456ghi789blahblah&query=Austin

... produces....

{"request":{"type":"City","query":"Austin, United States of America","language":"en","unit":"m"},"location":{"name":"Austin","country":"United States of America","region":"Texas","lat":"30.267","lon":"-97.743","timezone_id":"America\/Chicago","localtime":"2019-11-07 19:43","localtime_epoch":1573155780,"utc_offset":"-6.0"},"current":{"observation_time":"01:43 AM","temperature":8,"weather_code":122,"weather_icons":["https:\/\/assets.weatherstack.com\/images\/wsymbols01_png_64\/wsymbol_0004_black_low_cloud.png"],"weather_descriptions":["Overcast"],"wind_speed":15,"wind_degree":350,"wind_dir":"N","pressure":1027,"precip":2.2,"humidity":83,"cloudcover":100,"feelslike":6,"uv_index":0,"visibility":16,"is_day":"no"}}
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Support & Releases All times are GMT - 4 Hours
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber