egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Eggdrop 1.8.0 won't connect to dalnet
Goto page 1, 2  Next
 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help
View previous topic :: View next topic  
Author Message
CP1832
Halfop


Joined: 09 Oct 2014
Posts: 62

PostPosted: Wed Apr 29, 2020 9:23 am    Post subject: Eggdrop 1.8.0 won't connect to dalnet Reply with quote

Hi guys:

Sorry to bother but my eggdrop 1.8.0 isn't able to connect from a shell to dalnet. This same eggdrop (using the exact same .conf file) was connected to dalnet for a long time, however, the connection was dropped and now it can't reconnect. This is the error I'm constantly getting:
Code:
[09:47:52] Trying server [irc.dal.net]:6667
[09:47:52] DNS resolved irc.dal.net to 170.178.184.34
[09:47:52] net: connect! sock 8
[09:47:52] Connected to irc.dal.net
[09:47:52] net: eof!(read) socket 8
[09:47:52] Disconnected from irc.dal.net
The same thing happens to every other port I try to connect to:
Code:
set servers {
  irc.dal.net
  irc.dal.net:6660
  irc.dal.net:6661
  irc.dal.net:6662
  irc.dal.net:6663
  irc.dal.net:6664
  irc.dal.net:6665
  irc.dal.net:6666
  irc.dal.net:6668
  irc.dal.net:6669
  irc.dal.net:7000
  irc.dal.net:8000
  irc.dal.net:8001
  irc.dal.net:8002
  irc.dal.net:+6697
  irc.dal.net:+7000
  irc.dal.net:+7070
  irc.dal.net:+9999
}
If I modify the .conf file to connect to freenode, it works like a charm. What else can I do / check?
Back to top
View user's profile Send private message
willyw
Revered One


Joined: 15 Jan 2009
Posts: 1101

PostPosted: Wed Apr 29, 2020 9:37 am    Post subject: Re: Eggdrop 1.8.0 won't connect to dalnet Reply with quote

One way to investiage more -

Start bot with -n switch :

./eggdrop -n eggdrop.conf

so that it doesn't automatically go into background. You'll be able to see it, as it attempts to log into the irc server.

Hopefully, you'll be able to see something that helps.
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
willyw
Revered One


Joined: 15 Jan 2009
Posts: 1101

PostPosted: Wed Apr 29, 2020 9:40 am    Post subject: Re: Eggdrop 1.8.0 won't connect to dalnet Reply with quote

Another idea -

Does your shell have irssi installed on it?

irssi is a text based irc client. Launch it, and try to log in on Dalnet with it, just for the heck of it. Just to see if it, from that same shell, can connect to Dalnet.

Just type:
irssi
on the shell command line, and see what happens. If it is installed on the system, it'll run. If not, you'll get an error.
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
ComputerTech
Op


Joined: 22 Feb 2020
Posts: 152
Location: Northern Ireland

PostPosted: Wed Apr 29, 2020 4:51 pm    Post subject: Reply with quote

um i always use us.dal.net port 6667
just saying try us.dal.net always works for me for my bots Wink


oh and what do you have this set to

Code:

# What is your network?
#   0 = EFnet
#   1 = IRCnet
#   2 = Undernet
#   3 = DALnet
#   4 = +e/+I/max-modes 20 Hybrid
#   5 = Others
set net-type



it better be 3 for dalnet

0 is for freenode type networks and 3 for dalnet type networks Wink
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
CP1832
Halfop


Joined: 09 Oct 2014
Posts: 62

PostPosted: Wed Apr 29, 2020 6:24 pm    Post subject: Re: Eggdrop 1.8.0 won't connect to dalnet Reply with quote

ComputerTech wrote:
um i always use us.dal.net port 6667
just saying try us.dal.net always works for me for my bots Wink


oh and what do you have this set to
Code:
# What is your network?
#   0 = EFnet
#   1 = IRCnet
#   2 = Undernet
#   3 = DALnet
#   4 = +e/+I/max-modes 20 Hybrid
#   5 = Others
set net-type
it better be 3 for dalnet

0 is for freenode type networks and 3 for dalnet type networks Wink
My net-type is indeed set to 3
willyw wrote:
Another idea -

Does your shell have irssi installed on it?

irssi is a text based irc client. Launch it, and try to log in on Dalnet with it, just for the heck of it. Just to see if it, from that same shell, can connect to Dalnet.

Just type:
irssi
on the shell command line, and see what happens. If it is installed on the system, it'll run. If not, you'll get an error.
I tried to connect to dalnet and it seems there's some issue as I'm getting the following error:
Code:
22:19 -!- Irssi: Looking up irc.dal.net
22:19 -!- Irssi: Connecting to irc.dal.net [194.68.45.50] port 6667
22:19 -!- Irssi: Connection to irc.dal.net established
22:19 -!- Irssi: warning Connection reset by peer
22:19 -!- Irssi: Connection lost to irc.dal.net
How can I figure out more about this error?
Back to top
View user's profile Send private message
willyw
Revered One


Joined: 15 Jan 2009
Posts: 1101

PostPosted: Wed Apr 29, 2020 7:02 pm    Post subject: Re: Eggdrop 1.8.0 won't connect to dalnet Reply with quote

I don't know.
I was expecting for there to be more to the error message - to help give us some clues.
I wouldn't have been surprised if it had been something like : too many connections from your ip , if your bot is on a popular shell.

If you've tried it with the bot, using -n switch, you could then take it to an Eggdrop channel and ask there. You could pastebin whatever eggdrop shows you, and perhaps somebody might have some ideas. Freenode irc network is good. And the channel is: #eggdrop .

You could also - as an irssi problem - find some "help" type channel on Dalnet itself, and ask there.

I'm sorry that I don't have a direct answer for you.

When you do find it, please let us know what it was - it might be helpful info for somebody else someday.
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
willyw
Revered One


Joined: 15 Jan 2009
Posts: 1101

PostPosted: Wed Apr 29, 2020 7:05 pm    Post subject: Re: Eggdrop 1.8.0 won't connect to dalnet Reply with quote

Just remembered :

Besides watching it try to log in, when launched with the -n switch, you might want to experiment with the logging flags too.

They are listed in the eggdrop.conf that came with your bot.

Perhaps adding some would get it to log more, and you might spy a clue in the log.
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
ComputerTech
Op


Joined: 22 Feb 2020
Posts: 152
Location: Northern Ireland

PostPosted: Thu Apr 30, 2020 6:56 am    Post subject: Reply with quote

did you use the address us.dal.net as i suggested above ? could be a problem since thats the only address my bot uses Smile

Code:

Just remembered :

Besides watching it try to log in, when launched with the -n switch, you might want to experiment with the logging flags too.

They are listed in the eggdrop.conf that came with your bot.

Perhaps adding some would get it to log more, and you might spy a clue in the log


this also is a great idea of willyw
i recommend doing that also along with using address us.dal.net port 6667

and if you like come chat with us at #eggdrop dalnet or my channel on dalnet #computertech123
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
ComputerTech
Op


Joined: 22 Feb 2020
Posts: 152
Location: Northern Ireland

PostPosted: Thu Apr 30, 2020 7:12 am    Post subject: Reply with quote

ALSO this may sound stupid but how do you know the bot is NOT connecting to dalnet
try /whois botnick

and

have you did /msg botnick hello yet to it or is this bot brand new? Wink
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
CP1832
Halfop


Joined: 09 Oct 2014
Posts: 62

PostPosted: Mon May 04, 2020 1:10 pm    Post subject: Reply with quote

willyw wrote:
I don't know.
I was expecting for there to be more to the error message - to help give us some clues.
I wouldn't have been surprised if it had been something like : too many connections from your ip , if your bot is on a popular shell.

If you've tried it with the bot, using -n switch, you could then take it to an Eggdrop channel and ask there. You could pastebin whatever eggdrop shows you, and perhaps somebody might have some ideas. Freenode irc network is good. And the channel is: #eggdrop .

You could also - as an irssi problem - find some "help" type channel on Dalnet itself, and ask there.

I'm sorry that I don't have a direct answer for you.

When you do find it, please let us know what it was - it might be helpful info for somebody else someday.
I have already asked on the #eggdrop channel on freenode but I haven't received any answer.
willyw wrote:
Just remembered :

Besides watching it try to log in, when launched with the -n switch, you might want to experiment with the logging flags too.

They are listed in the eggdrop.conf that came with your bot.

Perhaps adding some would get it to log more, and you might spy a clue in the log.
Here's my log settings, just in case:
Code:
# This setting allows you the logging of raw incoming server traffic via
# console/log flag 'r', raw outgoing server traffic via console/log mode 'v',
# raw botnet traffic via console/log mode 't', and raw share traffic via
# console/log mode 'h'. These flags can create a large security hole,
# allowing people to see user passwords. This is now restricted to +n users
# only. Please choose your owners with care.
set raw-log 1

# This creates a logfile named eggdrop.log containing private msgs/ctcps,
# commands, errors, and misc. info from any channel.
logfile bdhorstvwx * "logs/dalnet"

# This creates a logfile named lamest.log containing joins, parts,
# netsplits, kicks, bans, mode changes, and public chat on the
# channel #lamest.
logfile m * "logs/private-dalnet"
ComputerTech wrote:
ALSO this may sound stupid but how do you know the bot is NOT connecting to dalnet
try /whois botnick

and

have you did /msg botnick hello yet to it or is this bot brand new? Wink
The eggdrop keeps trying to reconnect, constantly, and the /whois doesn't find it.
ComputerTech wrote:
did you use the address us.dal.net as i suggested above ? could be a problem since thats the only address my bot uses Smile

Code:

Just remembered :

Besides watching it try to log in, when launched with the -n switch, you might want to experiment with the logging flags too.

They are listed in the eggdrop.conf that came with your bot.

Perhaps adding some would get it to log more, and you might spy a clue in the log


this also is a great idea of willyw
i recommend doing that also along with using address us.dal.net port 6667

and if you like come chat with us at #eggdrop dalnet or my channel on dalnet #computertech123
I have also tried to connect to us.dal.net 6667 to the same results on both eggdrop and irssi:
Code:
17:07 -!- Irssi: Looking up us.dal.net
17:07 -!- Irssi: Connecting to us.dal.net [154.35.138.250] port 6667
17:07 -!- Irssi: Connection to us.dal.net established
17:07 -!- Irssi: Connection lost to us.dal.net
Back to top
View user's profile Send private message
ComputerTech
Op


Joined: 22 Feb 2020
Posts: 152
Location: Northern Ireland

PostPosted: Mon May 04, 2020 3:37 pm    Post subject: Reply with quote

hmm have you set all the areas for the bots name?
sometimes that happens to me, like you set one nick at one place then a different one at another place, just a suggestion

also
ir you like next time your on #eggdrop freenode say my nick "computertech" and i will come help i am also on dalnet if you want tell me your channel name and i can also help you out Cool
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
simo
Master


Joined: 22 Mar 2015
Posts: 484

PostPosted: Thu May 21, 2020 10:24 am    Post subject: Reply with quote

i believe it might be cause a free shell is used like xshellz wich uses the same IP and it has been seen as connection flood from same IP thats why it might be why it keeps disconnecting
_________________
Coming together is a beginning, staying together is progress, working together is succes.
Back to top
View user's profile Send private message
willyw
Revered One


Joined: 15 Jan 2009
Posts: 1101

PostPosted: Thu May 21, 2020 10:46 am    Post subject: Reply with quote

simo wrote:
i believe it might be cause a free shell is used like xshellz wich uses the same IP and it has been seen as connection flood from same IP thats why it might be why it keeps disconnecting


From a previous post here:
willyw wrote:
...
I wouldn't have been surprised if it had been something like : too many connections from your ip , if your bot is on a popular shell.


Although I also expected that it would clearly say so.
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
simo
Master


Joined: 22 Mar 2015
Posts: 484

PostPosted: Thu May 21, 2020 12:39 pm    Post subject: Reply with quote

oh i must have overlooked that willyw
_________________
Coming together is a beginning, staying together is progress, working together is succes.


Last edited by simo on Thu May 21, 2020 8:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
ComputerTech
Op


Joined: 22 Feb 2020
Posts: 152
Location: Northern Ireland

PostPosted: Thu May 21, 2020 1:40 pm    Post subject: Reply with quote

why not just telnet the bot and set console +r and watch whats wrong
that what you can see if it's connection problem for the limit of the ip or something else.


ps simo not caesar it's willyw Razz
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help All times are GMT - 4 Hours
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber