egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

UTF-8 not working

 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help
View previous topic :: View next topic  
Author Message
simo
Owner


Joined: 22 Mar 2015
Posts: 536

PostPosted: Sat Aug 08, 2020 10:45 am    Post subject: UTF-8 not working Reply with quote

we are using m00nies tcl for YT the latest one and we got our own API key and it all works fine exept it doesnt output UTF8 no matter what we do :
we tested with the .tcl encoding system in PL and got utf-8 so thats fine
we installed the needed packages (Ubuntu 20.04 OS)
tcl tcl-dev tcllib tcl-tls

still when we try to use utf8 it doesnt output proper we are kinda stuck what else to try

using:
eggdrop v1.8.4
Tcl library: /usr/share/tcltk/tcl8.6
Tcl version: 8.6.10 (header version 8.6.10)
Tcl is threaded
TLS support is enabled
TLS library: OpenSSL 1.1.1f 31 Mar 2020





for locale this is what we have:

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
_________________
Coming together is a beginning, staying together is progress, working together is succes.


Last edited by simo on Thu Aug 13, 2020 10:20 am; edited 1 time in total
Back to top
View user's profile Send private message
Arnold_X-P
Master


Joined: 30 Oct 2006
Posts: 200
Location: DALnet - Trinidad - Beni - Bolivia

PostPosted: Thu Aug 13, 2020 12:08 am    Post subject: Re: UTF-8 not working Reply with quote

hi bro (in eggdrop.conf) try with:
Quote:
set out-encoding "utf-8"
set fallback-encoding "cp1251"


but you have to remove any tcl you try to convert to utf-8 for example:
utf-8.tcl
_________________
Very Happy thanks to that they help, that others learn Very Happy
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
simo
Owner


Joined: 22 Mar 2015
Posts: 536

PostPosted: Thu Aug 13, 2020 10:16 am    Post subject: Reply with quote

thanx for your reply Arnold_X-P
i tried that but it didnt work
_________________
Coming together is a beginning, staying together is progress, working together is succes.
Back to top
View user's profile Send private message
Arnold_X-P
Master


Joined: 30 Oct 2006
Posts: 200
Location: DALnet - Trinidad - Beni - Bolivia

PostPosted: Wed Sep 30, 2020 10:59 pm    Post subject: Reply with quote

it works very well for me, but try to have with this
Quote:
set out-encoding "utf-8"
set fallback-encoding "windows-1250"

_________________
Very Happy thanks to that they help, that others learn Very Happy
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber