egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

make gseen answer in another language

 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Modules & Programming
View previous topic :: View next topic  
Author Message
agathodaimon
Voice


Joined: 21 Aug 2005
Posts: 29

PostPosted: Thu Sep 01, 2005 4:44 am    Post subject: make gseen answer in another language Reply with quote

Hi
how do i make gseen answer in a lang.file of my own?.
I read the readme file ..i looked around the forum to find an answer..but nothing..
any ideas?

Thx
Back to top
View user's profile Send private message
demond
Revered One


Joined: 12 Jun 2004
Posts: 3073
Location: San Francisco, CA

PostPosted: Thu Sep 01, 2005 4:57 am    Post subject: Reply with quote

it's all in gseen.conf:
Code:

# load the English language file
loadseenslang "en" "English" language/gseen.en.lang

# load the German language file
loadseenslang "de" "Deutsch" language/gseen.de.lang

# set the default language to english...
set default-slang "en"

# ... but let #xwp use the german langfile
setchanseenlang #xwp "de"
Back to top
View user's profile Send private message Visit poster's website
agathodaimon
Voice


Joined: 21 Aug 2005
Posts: 29

PostPosted: Thu Sep 01, 2005 5:56 am    Post subject: and the answer would be..... Reply with quote

[11:54] Successfully loaded eggping.tcl 1.0.6 by Souperman!
[11:54] Can't open gseen file, creating new database...
[11:54] gseen.mod v1.0.9 loaded.
[11:54] Module loaded: gseen
[11:54] Tcl error in file 'oblio.conf':
[11:54] invalid command name "loadseenslang"
while executing
"loadseenslang "en" "English" language/gseen.en.lang"
(file "gseen.conf" line 16)
invoked from within
"source gseen.conf"
(file "kiss.conf" line 1356)
[11:54] * CONFIG FILE NOT LOADED (NOT FOUND, OR ERROR)
oblio@oblio:~/eggdrop>
Back to top
View user's profile Send private message
demond
Revered One


Joined: 12 Jun 2004
Posts: 3073
Location: San Francisco, CA

PostPosted: Thu Sep 01, 2005 6:03 am    Post subject: Reply with quote

likely old gseen version, get the latest
Back to top
View user's profile Send private message Visit poster's website
agathodaimon
Voice


Joined: 21 Aug 2005
Posts: 29

PostPosted: Thu Sep 01, 2005 6:06 am    Post subject: allrighty then Reply with quote

ok thx
will do
Back to top
View user's profile Send private message
Alchera
Revered One


Joined: 11 Aug 2003
Posts: 3344
Location: Ballarat Victoria, Australia

PostPosted: Thu Sep 01, 2005 10:02 pm    Post subject: Reply with quote

demond wrote:
likely old gseen version, get the latest

Nope!

They didn't copy the *.lang files from ~src~mod~gseen.mod into ~language

Quote:
Don't forget to copy the langfiles from eggdrop1.6.2/src/mod/gseen.mod/ to eggdrop/language.

The README is old.
_________________
Add [SOLVED] to the thread title if your issue has been.
Search | FAQ | RTM
Back to top
View user's profile Send private message Visit poster's website
demond
Revered One


Joined: 12 Jun 2004
Posts: 3073
Location: San Francisco, CA

PostPosted: Thu Sep 01, 2005 10:10 pm    Post subject: Reply with quote

nope, that's not a lang file problem:
Code:

[11:54] Module loaded: gseen
[11:54] Tcl error in file 'oblio.conf':
[11:54] invalid command name "loadseenslang"


...or it is, but in such case [loadseenslang] is implemented/loaded only if language files exist, which is lame
Back to top
View user's profile Send private message Visit poster's website
Alchera
Revered One


Joined: 11 Aug 2003
Posts: 3344
Location: Ballarat Victoria, Australia

PostPosted: Fri Sep 02, 2005 2:37 am    Post subject: Reply with quote

Latest (and last version) is gseen.mod v1.1.1.dev3. Apparently gseen.mod is not being further developed or supported by the author.
_________________
Add [SOLVED] to the thread title if your issue has been.
Search | FAQ | RTM
Back to top
View user's profile Send private message Visit poster's website
demond
Revered One


Joined: 12 Jun 2004
Posts: 3073
Location: San Francisco, CA

PostPosted: Fri Sep 02, 2005 2:41 am    Post subject: Reply with quote

I run 1.1 without any problems
Back to top
View user's profile Send private message Visit poster's website
Alchera
Revered One


Joined: 11 Aug 2003
Posts: 3344
Location: Ballarat Victoria, Australia

PostPosted: Fri Sep 02, 2005 7:05 pm    Post subject: Reply with quote

demond wrote:
I run 1.1 without any problems

I use dev3 and have never had a drama either. Smile
_________________
Add [SOLVED] to the thread title if your issue has been.
Search | FAQ | RTM
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Modules & Programming All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber