egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Bandwidth Monitor

 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Support & Releases
View previous topic :: View next topic  
Author Message
NRG88
Voice


Joined: 17 Nov 2005
Posts: 2

PostPosted: Thu Nov 17, 2005 10:23 pm    Post subject: Bandwidth Monitor Reply with quote

Hi, I've downloaded the bandwidth monitor ( http://www.egghelp.org/cgi-bin/tcl_archive.tcl?mode=download&id=1134 ). The problem is, that i'm using windrop, and it isn't working under windows. Possibly the following (bolded) two lines have to be rewritten:
Code:
variable api "/proc/net/dev"
variable interface "eth0:LAN,eth1:LAN,ppp0:WAN" ;# for windows win:<something> without the others..

...they are from...
Code:
namespace eval bandwidth {
 
  variable api "/proc/net/dev"

  ##########################################
  # <interface>:<alias> seperated by a ','
  # or a hex representation of 2e, for
  # windows use only win:<whatever>
  ##########################################
  variable interface "eth0:LAN,eth1:LAN,ppp0:WAN" ;# for windows win:<something> without the others..

Can someone help me with this?
Back to top
View user's profile Send private message
Alchera
Revered One


Joined: 11 Aug 2003
Posts: 3344
Location: Ballarat Victoria, Australia

PostPosted: Thu Nov 17, 2005 10:57 pm    Post subject: Reply with quote

Quote:
# for windows win:<something> without the others..

Tried System Information?

Do you have onboard ethernet?
_________________
Add [SOLVED] to the thread title if your issue has been.
Search | FAQ | RTM
Back to top
View user's profile Send private message Visit poster's website
demond
Revered One


Joined: 12 Jun 2004
Posts: 3073
Location: San Francisco, CA

PostPosted: Fri Nov 18, 2005 1:34 am    Post subject: Reply with quote

simply put there win:whatever, it doesn't matter what whatever will be, it's not used by the script (stats are obtained by netstat -e command)

api is not used on Windows either (there is no /proc kernel interface on that operating system)
_________________
connection, sharing, dcc problems? click <here>
before asking for scripting help, read <this>
use [code] tag when posting logs, code
Back to top
View user's profile Send private message Visit poster's website
NRG88
Voice


Joined: 17 Nov 2005
Posts: 2

PostPosted: Fri Nov 18, 2005 6:05 am    Post subject: Reply with quote

ok, i'll try it Smile

Edit: tried it, and nothing happens. It loads the script, but no reactions to the bot Sad it does nothing.. Chaneged it to win:whatever
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Support & Releases All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber