egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

incith:weather (2.8p) (Dec. 18th, 2008)
Goto page Previous  1, 2, 3 ... 18, 19, 20, 21  Next
 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Support & Releases
View previous topic :: View next topic  
Author Message
CtrlAltDel
Halfop


Joined: 02 Jun 2004
Posts: 49

PostPosted: Sat Aug 08, 2015 2:35 pm    Post subject: Reply with quote

CP1832 wrote:
shadrach wrote:
All requests now returning 'Please refine your search.' Crying or Very sad
Yes, that happened to me as well. I replaced "http://classic.wunderground.com/cgi-bin/findweather/getForecast?query=" to "http://www.wunderground.com/cgi-bin/findweather/getForecast?query=" and now the script works again.


Worked here, too. Thanks!
Back to top
View user's profile Send private message
JJTX
Voice


Joined: 05 May 2015
Posts: 5
Location: United States

PostPosted: Thu Aug 13, 2015 7:36 pm    Post subject: Reply with quote

simboy1234 wrote:
CP1832 wrote:
shadrach wrote:
All requests now returning 'Please refine your search.' Crying or Very sad
Yes, that happened to me as well. I replaced "http://classic.wunderground.com/cgi-bin/findweather/getForecast?query=" to "http://www.wunderground.com/cgi-bin/findweather/getForecast?query=" and now the script works again.


Thank you for the fix, that worked.


I did the same thing. It worked here as well.
Back to top
View user's profile Send private message
JJTX
Voice


Joined: 05 May 2015
Posts: 5
Location: United States

PostPosted: Sat Dec 26, 2015 7:39 pm    Post subject: Reply with quote

speechles wrote:
New Version: Incith-weather 2.9d
Http://ereader.kiczek.com/incith-weather.tcl

Now before you get too excited. This is an interim broken release. !fc and !sky do not function yet. You have !time and !wz only. !wz is also partially broken. This is because of the variables not exposed in javascript having data we need to complete our weather calls. Trying several sneaky ways to get them to expose the data. There is also no support for multiple locations, yet... There will be, this is just the early advance copy for people watching this thread right now. Expect more updates soon.


We very much appreciate your hard work on this script so we can keep using it. Nothing else comes close.

However that said, I get please-refine-your-search response from the bot every time I try a !WZ or the !w I prefer.

FC as well. "please refine search".

So I assume this is still being researched.

Thanks again for the update.
Back to top
View user's profile Send private message
shadrach
Halfop


Joined: 14 Dec 2007
Posts: 70

PostPosted: Thu Mar 03, 2016 7:45 pm    Post subject: Reply with quote

Change

Code:
proc fetch_html {query {query_url "http://www.wunderground.com/cgi-bin/findweather/getForecast?query="} {no_format 0}} {


to

Code:
proc fetch_html {query {query_url "https://www.wunderground.com/cgi-bin/findweather/getForecast?query="} {no_format 0}} {


http:// to https://
Back to top
View user's profile Send private message MSN Messenger
Mysticales
Voice


Joined: 18 Oct 2011
Posts: 26

PostPosted: Fri Mar 04, 2016 12:08 am    Post subject: Reply with quote

That http to https didnt seem to solve the "Please refine your search" issue. Least it didnt for me?
_________________
~Battlez-avec la Mystique?~
Back to top
View user's profile Send private message
shadrach
Halfop


Joined: 14 Dec 2007
Posts: 70

PostPosted: Fri Mar 04, 2016 2:33 am    Post subject: Reply with quote

Mysticales wrote:
That http to https didnt seem to solve the "Please refine your search" issue. Least it didnt for me?


Worked for me on two different bots which before the edit returned the 'refine' message. Did you remember to rehash?
Back to top
View user's profile Send private message MSN Messenger
lorddragon
Voice


Joined: 04 Mar 2016
Posts: 1

PostPosted: Fri Mar 04, 2016 9:25 am    Post subject: Reply with quote

I also tried changing the url to https instead of http, but then instead of "refine your search", i got "failed to connect" which tells me the script is not setup for SSL. I installed tlstcl packages and tried with that but still nothing
Back to top
View user's profile Send private message
shadrach
Halfop


Joined: 14 Dec 2007
Posts: 70

PostPosted: Fri Mar 04, 2016 11:03 am    Post subject: Reply with quote

I am not a coder by any means but i think the script has failsafes whereby if the main wunderground site cannot be read then the fallback is the classic site which is now redundant and redirects to the https main site and lastly the mobile site which actually is the site the script is returning info from it seems. Perhaps if someone could modify the code so only the mobile site is polled it would be more efficient.
Back to top
View user's profile Send private message MSN Messenger
mtnvortest
Voice


Joined: 04 Mar 2016
Posts: 6

PostPosted: Fri Mar 04, 2016 12:50 pm    Post subject: Reply with quote

I seem to be having the same issue as a few others here. After changing http to https, I am getting "failed to connect".
Back to top
View user's profile Send private message
shadrach
Halfop


Joined: 14 Dec 2007
Posts: 70

PostPosted: Fri Mar 04, 2016 2:50 pm    Post subject: Reply with quote

Sounds like you need ssl installed on the bot's machine: tcl-tls
Back to top
View user's profile Send private message MSN Messenger
mtnvortest
Voice


Joined: 04 Mar 2016
Posts: 6

PostPosted: Fri Mar 04, 2016 4:41 pm    Post subject: Reply with quote

Thanks. Looking into that now, but I do believe we have the Funtoo equivalent with dev-tcltk/tls.
Back to top
View user's profile Send private message
creasy
Voice


Joined: 05 Mar 2016
Posts: 21

PostPosted: Sun Mar 06, 2016 5:18 am    Post subject: Reply with quote

lorddragon wrote:
I also tried changing the url to https instead of http, but then instead of "refine your search", i got "failed to connect" which tells me the script is not setup for SSL. I installed tlstcl packages and tried with that but still nothing

Adding SSL settings under the "browser" we are using fixed it for me:
Code:
      # the "browser" we are using
      set ua "Lynx/2.8.5rel.1 libwww-FM/2.14 SSL-MM/1.4.1 OpenSSL/0.9.7e"
      ::http::register https 443 [list ::tls::socket -request 1 -require 0 -ssl3 1 -tls1 1]
Back to top
View user's profile Send private message
mtnvortest
Voice


Joined: 04 Mar 2016
Posts: 6

PostPosted: Sun Mar 06, 2016 6:00 pm    Post subject: Reply with quote

Thanks, creasy. It looks like wundergroud removed the redirect for https, so the script is currently working again.
Back to top
View user's profile Send private message
creasy
Voice


Joined: 05 Mar 2016
Posts: 21

PostPosted: Mon Mar 07, 2016 9:18 am    Post subject: Reply with quote

There is also the issue of no results or multiple results found. In the 1st case the bot doesn't respond at all, while in the 2nd instead of a list of possible hits it returns
Code:
High/Low: Unavailable; Wind: Calm

Any ideas on how to fix this?
Back to top
View user's profile Send private message
planetb
Voice


Joined: 21 Jan 2011
Posts: 6

PostPosted: Wed Mar 23, 2016 5:00 pm    Post subject: weather stopped working recently Reply with quote

Started to see this error today (from irc logs, it looks like it worked yesterday)

16:12] <@lj> .wz 21061
[16:12] <@PB> Please refine your search.

[16:13] <@lj> .wz
[16:13] <@PB> Please visit http://classic.wunderground.com for more details on searching methods.

Have not looked at the code yet. Looks like https redir started again..
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Support & Releases All times are GMT - 4 Hours
Goto page Previous  1, 2, 3 ... 18, 19, 20, 21  Next
Page 19 of 21

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber