egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

listen-addr suddenly not working!

 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help
View previous topic :: View next topic  
Author Message
Landslyde
Halfop


Joined: 01 May 2014
Posts: 43

PostPosted: Wed Aug 10, 2016 5:33 pm    Post subject: listen-addr suddenly not working! Reply with quote

v1.8 eggdrop

I just added a small script, restarted my bot and got this:

Code:
[15:25:12] Couldn't listen on port '7032' on the given address. Please make sure 'listen-addr' is set properly or try choosing a different port.
    while executing
"listen 7032 all"


She's been using that port for a long time. So I thought it might be some kind of conflict from the new script. I commented it out and tried again. Same thing. So i ran netstat -nlp and it shows nothing using that port.

Code:
 root@landslyde:~# netstat -nlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      421/sshd
tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      6478/exim4
tcp6       0      0 :::80                   :::*                    LISTEN      458/apache2
tcp6       0      0 :::22                   :::*                    LISTEN      421/sshd
tcp6       0      0 ::1:25                  :::*                    LISTEN      6478/exim4
tcp6       0      0 2604:180:0:c62:21::7033 :::*                    LISTEN      547/eggdrop
udp        0      0 0.0.0.0:55620           0.0.0.0:*                           547/eggdrop
udp        0      0 0.0.0.0:45766           0.0.0.0:*                           547/eggdrop
Active UNIX domain sockets (only servers)
Proto RefCnt Flags       Type       State         I-Node   PID/Program name    Path
unix  2      [ ACC ]     STREAM     LISTENING     2643881473 1/init              /run/systemd/private
unix  2      [ ACC ]     SEQPACKET  LISTENING     2643881497 1/init              /run/udev/control
unix  2      [ ACC ]     STREAM     LISTENING     2643881500 1/init              /run/systemd/journal/stdout


This is my vps and i'm the only one on it.

I've also tried rebooting with no success.

Please help me fix this. I don't have any understand beyond what I've done to try to fix it.


Last edited by Landslyde on Wed Aug 10, 2016 6:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
Madalin
Master


Joined: 24 Jun 2005
Posts: 301
Location: Constanta, Romania

PostPosted: Wed Aug 10, 2016 5:55 pm    Post subject: Reply with quote

Try move the listen adresse line... to be the first line from the file
_________________
https://github.com/MadaliNTCL - To chat with me: https://tawk.to/MadaliNTCL
Back to top
View user's profile Send private message Send e-mail Visit poster's website Yahoo Messenger
Fire-Fox
Master


Joined: 23 Sep 2006
Posts: 254
Location: /dev/null

PostPosted: Wed Aug 24, 2016 11:46 am    Post subject: Reply with quote

What is
Code:
listen-addr
set to?
_________________
GreatZ
Fire-Fox | Denmark

Scripts: Relay | Store Text
Back to top
View user's profile Send private message MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber