egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

How do I get Eggdrop to do an SASL login ?

 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help
View previous topic :: View next topic  
Author Message
willyw
Owner


Joined: 15 Jan 2009
Posts: 970

PostPosted: Fri Sep 21, 2018 10:51 am    Post subject: How do I get Eggdrop to do an SASL login ? Reply with quote

Just had an interesting chat with a friend who use Amazon Web Service - AWS - shell to house his eggdrop bot.

And he was trying to make that bot connect to Freenode.

Freenode balked, wouldn't let his bot connect, saying that an SASL connection was required.

So we looked around, and found some info online, etc.

I don't have an AWS account, but I tried it on a bot of mine that is on Freenode. Works fine. Bot logs in and ids with Nickserv.

Here's what I did:

1.) Go here: https://nullroute.eu.org/~grawity/journal-2013.html
and scroll down, or text search and find: SASL authentication in Eggdrop
and read those three paragraphs.
Not absolutely necessary, but it helps.

2.) Go here: https://gist.github.com/grawity/4455067

Read some.

Then find two tcl scripts there:
https://gist.github.com/grawity/4455067#file-g_base64-tcl
and
https://gist.github.com/grawity/4455067#file-g_cap-tcl

On the right side of the page of each, click on the Raw button.
That opens another page, and it is plain text. I simply right clicked, got a pop up menu, chose Select All to highlight, and copied.
Then I went to shell, creating new text file with nano, and pasted.
Saved.
That's how I created each of those two .tcl files.

3.) Have a look at them.

One of them must be loaded before the other. Pay attention.

Also, one of them has a few lines of configuration. Actually, you must copy them over to your working eggdrop.conf. I simply pasted them just below the source lines that load the two scripts.

I edited only one line in this section : # password for PLAIN
You'll see.

Also, notice that the script uses $username ?
Go look in the main part of your working eggdrop.conf, and be sure it is set correctly.

That's it.

I .restarted bot, and watched. It logged on to Freenode, and did the SASL thing, and was id'd with NickServ. Worked first time.

I hope this helps somebody.
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !


Last edited by willyw on Fri Sep 21, 2018 10:55 am; edited 1 time in total
Back to top
View user's profile Send private message
willyw
Owner


Joined: 15 Jan 2009
Posts: 970

PostPosted: Fri Sep 21, 2018 10:54 am    Post subject: Re: How do I get Eggdrop to do an SASL login ? Reply with quote

Note:

My friend discovered something interesting.
His bot would not load... errored out with error that it couldn't accept bind type raw .

Discovered that he had to load these script AFTER loading alltools.tcl .

I have no idea why, as I thought alltools was just a bunch of procs to create some handy commands, whereas the bind raw type is (I thought) part of TCL itself.

Anyway - I'd loaded these scripts and the corresponding config lines, at the very bottom of bot's working eggdrop.conf, so I didn't encounter the problem.
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
grawity
Voice


Joined: 20 Apr 2009
Posts: 1

PostPosted: Sun Sep 30, 2018 3:49 pm    Post subject: Reply with quote

willyw wrote:
Also, notice that the script uses $username ?
Go look in the main part of your working eggdrop.conf, and be sure it is set correctly.


You can set sasl-user to anything you want, instead of using the $username default.

willyw wrote:
My friend discovered something interesting.
His bot would not load... errored out with error that it couldn't accept bind type raw .

Discovered that he had to load these script AFTER loading alltools.tcl .

I have no idea why, as I thought alltools was just a bunch of procs to create some handy commands, whereas the bind raw type is (I thought) part of TCL itself.


I don't know why alltools would be required. I have never used it in my bots; the bind always worked on a barebone eggdrop.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber