egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

module problem with eggdrop1.6.21 HELP-ME

 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help
View previous topic :: View next topic  
Author Message
Suratka
Voice


Joined: 25 Jun 2016
Posts: 6

PostPosted: Sun Nov 03, 2019 5:51 pm    Post subject: module problem with eggdrop1.6.21 HELP-ME Reply with quote

I'm trying to install module stats.mod v4
and I get these errors after the "make config" command
can someone help me?


Configuring module 'compress'.
configure: loading cache ../../../config.cache
configure: error: `CFLAGS' was not set in the previous run
configure: error: in `/home/aktarus/eggdrop2/eggdrop16/src/mod/compress.mod':
configure: error: changes in the environment can compromise the build
configure: error: run `make distclean' and/or `rm ../../../config.cache' and start over

Configuring module 'dns'.
configure: loading cache ../../../config.cache
configure: error: `CFLAGS' was not set in the previous run
configure: error: in `/home/aktarus/eggdrop2/eggdrop16/src/mod/dns.mod':
configure: error: changes in the environment can compromise the build
configure: error: run `make distclean' and/or `rm ../../../config.cache' and start over
Back to top
View user's profile Send private message AIM Address
willyw
Revered One


Joined: 15 Jan 2009
Posts: 1095

PostPosted: Sun Nov 03, 2019 9:35 pm    Post subject: Re: module problem with eggdrop1.6.21 HELP-ME Reply with quote

mascalzone wrote:
I'm trying to install module stats.mod v4
and I get these errors after the "make config" command
can someone help me?
...


I am not a compile wizard, but while you wait for somebody else to respond, here's something to consider:

Visit:
https://www.kreativrauschen.com/stats.mod/download/
and it says that stats.mod version 1.4 is not the stable version. Is that the one you are trying to use? If so, how about trying the 1.3 version instead?

Also, version 1.6.21 of eggdrop is old now. As far as I know, there's nothing technically wrong with it, it's just old.
Version 1.8.4 is the newest. And if you visit here:
https://www.kreativrauschen.com/stats.mod/download/
there's a version of stats.mod there, for 1.8.4 .
Just something to think about ....

I recall that towards the end of 1.6.21's time, it was not unusual to run into compile problems. It wouldn't find what it needed, etc. I can't tell from your post if you could get 1.6.21 to compile, just plain, with no extra modules - or not.
Anyway - you might like to visit:
http://eggwiki.org/Main_Page
( it's on the Help menu, found here: http://www.eggheads.org/ )
and go through all the links on that page, regarding compile problems.

Let us know whatever you discover, especially if you get it to work.

I hope this helps.
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber