egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Eggdrop stop replying to telnet

 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help
View previous topic :: View next topic  
Author Message
CrazyCat
Owner


Joined: 13 Jan 2002
Posts: 533
Location: France

PostPosted: Mon Feb 24, 2020 5:56 am    Post subject: Eggdrop stop replying to telnet Reply with quote

Hi there,

I have some eggdrops which stop replying to telnet after a certain uptime, that's really weird:
Code:
eggdrop@myhost:~/eggdrop$ telnet myhost 3300
Trying myhost...
Connected to myhost.
Escape character is '^]'.
Connection closed by foreign host.

I kill the bot process and launch again
Code:
eggdrop@myhost:~/eggdrop$ telnet myhost 3300
Trying myhost...
Connected to myhost.
Escape character is '^]'.
  ___                 _
 | __| __ _  __ _  __| | _ _  ___  _ __
 | _| / _` |/ _` |/ _` || '_|/ _ \| '_ \
 |___|\__, |\__, |\__,_||_|  \___/| .__/
      |___/ |___/                 |_|

  Copyright (C) 1997 Robey Pointer
  Copyright (C) 1999 - 2008 Eggheads Development Team


Artus  (Eggdrop v1.8.4 (C) 1997 Robey Pointer (C) 2010-2018 Eggheads)

I have other eggdrops on this host, with quite identical config (only names and ports are different, and some scripts), some of them works well, some of them have the same trouble.

The eggdrop with this trouble are hubs in my botnet, do you think it could be the source of the trouble ?

P.S.: here is my bottree:
Code:
[11:04:17] #CrazyCat# bottree
Artus
  |--Excalibur
  |    `--CrazyEgg
  |--Brandelis
  |--Viviane
  |--Lancelot
  |    `--_BS00
  |         |--_BS02
  |         |--_BS01
  |         |--_BS09
  |         |--_BS07
  |         |--_BS08
  |         |--_BS06
  |         |--_BS05
  |         |--_BS04
  |         `--_BS03
  |--Gauvain
  |--Morgane
  |--Mordret
  |--Guenievre
  |--Perceval
  |--Myrddin
  `--Galaad

Artus and Lancelot often have the trouble
_________________
https://www.eggdrop.fr - French speaking IRC network
Back to top
View user's profile Send private message Visit poster's website
willyw
Revered One


Joined: 15 Jan 2009
Posts: 1095

PostPosted: Mon Feb 24, 2020 9:18 am    Post subject: Re: Eggdrop stop replying to telnet Reply with quote

What I have had happen - a few times, certainly not always - regarding connections dying, is with dcc chat to bot.

I remember that once, it was on a shell that a friend had given me. In other words, I knew the admin and he was willing to look into it. He discovered some setting in linux, such that after x minutes, it would kill an idle connection.
He changed that setting, and the problem was fixed.

The few other times it has happened to me over the years, it was on shells where I did not know the admin so well. So I made a little script, such that when I logged into bot via dcc chat, the bot would send me a blank line of text in the partyline every x minutes. The blank line is tolerable, appearing in the partyline. And it fixed the problem.

Thus, I cannot help but wonder if you've got the same problem.... that the shell itself is killing the connection due to inactivity.

I suppose that with some careful experimenting, you could find out if this is it.
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
CrazyCat
Owner


Joined: 13 Jan 2002
Posts: 533
Location: France

PostPosted: Mon Feb 24, 2020 11:01 am    Post subject: Reply with quote

The trouble is that just a few eggdrops have this issue, others (same shell, same compiled eggdrop, just the .conf is changed) haven't.
When the DCC is enabled, I haven't any trouble. But I can't telnet the faulty eggdrops unless I stop & restart them. And it's clearly the eggdrop which doesn't answer totally, it blocks before sending the banner, like if it takes a long time to got the connection.

Peharps the hub consumes too much sockets ?
_________________
https://www.eggdrop.fr - French speaking IRC network
Back to top
View user's profile Send private message Visit poster's website
willyw
Revered One


Joined: 15 Jan 2009
Posts: 1095

PostPosted: Mon Feb 24, 2020 12:18 pm    Post subject: Reply with quote

CrazyCat wrote:
The trouble is that just a few eggdrops have this issue, others (same shell, same compiled eggdrop, just the .conf is changed) haven't.
...
Peharps the hub consumes too much sockets ?


Perhaps it is that one eggdrop is idle for too long, and another isn't ?
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
willyw
Revered One


Joined: 15 Jan 2009
Posts: 1095

PostPosted: Mon Feb 24, 2020 12:20 pm    Post subject: Reply with quote

Write a simple script. Have the bot ping itself, once every five minutes. See if that makes a difference. Can't hurt. Smile
_________________
For a fun (and popular) Trivia game, visit us at: irc.librairc.net #science-fiction . Over 300K Q & A to play in BogusTrivia !
Back to top
View user's profile Send private message
CrazyCat
Owner


Joined: 13 Jan 2002
Posts: 533
Location: France

PostPosted: Tue Feb 25, 2020 3:07 am    Post subject: Reply with quote

Well, the eggdrops works well. It reacts to commands without any trouble.
It's just telnet (I don't test DCC chat, I'll do it soon) which doesn't answer completely.

N.B.: as I showed in my first message, the connection is established ("Connected to myhost., Escape character is '^]'") and freeze at this time.

I'll try to measure CPU and RAM consumption for my eggdrops and see Smile
_________________
https://www.eggdrop.fr - French speaking IRC network
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Eggdrop Help All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber