egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Google search
Goto page Previous  1, 2, 3  Next
 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Scripting Help
View previous topic :: View next topic  
Author Message
simo
Owner


Joined: 22 Mar 2015
Posts: 646

PostPosted: Sat Mar 27, 2021 5:32 pm    Post subject: Reply with quote

afaik i got all packages loaded as well its the API and id im missing
Back to top
View user's profile Send private message
simo
Owner


Joined: 22 Mar 2015
Posts: 646

PostPosted: Sat Mar 27, 2021 5:46 pm    Post subject: Reply with quote

manages to create the API key cant seem to create an ID
Back to top
View user's profile Send private message
ComputerTech
Master


Joined: 22 Feb 2020
Posts: 374

PostPosted: Sat Mar 27, 2021 5:58 pm    Post subject: Reply with quote

Instructions: for Engine ID

1: https://cse.google.com/cse/create/new

2: enter in "Sites to search" *.google.com

3: enter in Name of search engine Google

4: Click "Public URL"

5: Copy the ID from this url

Example
Code:

https://cse.google.com/cse?cx=8bff70e62d3a0f8d7


from cx= is your Engine ID :wink

6: Go to https://cse.google.com/cse/setup/basic?cx=Your-id-here

and make sure "Search the entire web" is turned On

Instruction: for Google Custom Search API Key

1: https://developers.google.com/custom-search/v1/overview (Make Sure you are signed into your Google Account)

2: Click "Get a Key"

3: Copy your API Key
_________________
ComputerTech


Last edited by ComputerTech on Sat Mar 27, 2021 6:16 pm; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail Visit poster's website
simo
Owner


Joined: 22 Mar 2015
Posts: 646

PostPosted: Sat Mar 27, 2021 6:12 pm    Post subject: Reply with quote

hm i followed all that and yet i keep gettin message about the API key not being proper
Back to top
View user's profile Send private message
ComputerTech
Master


Joined: 22 Feb 2020
Posts: 374

PostPosted: Sat Mar 27, 2021 6:13 pm    Post subject: Reply with quote

Above instructions are for the Engine ID, i thought you said you got the API? or which do you need currently?
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
simo
Owner


Joined: 22 Mar 2015
Posts: 646

PostPosted: Sat Mar 27, 2021 6:16 pm    Post subject: Reply with quote

Tcl error [goo:gle]: key "searchInformation" not known in dictionary

i created the API ealier tho and added it
Back to top
View user's profile Send private message
ComputerTech
Master


Joined: 22 Feb 2020
Posts: 374

PostPosted: Sat Mar 27, 2021 6:17 pm    Post subject: Reply with quote

did you rehash after placing both Engine ID and API Key? and when creating the Engine ID did you receive the message "Engine Created Successfully" ?


EDIT

what term are you searching btw? from my past tests, searches with the keys [ ] { } ane etc don't yet work
_________________
ComputerTech


Last edited by ComputerTech on Sat Mar 27, 2021 6:22 pm; edited 2 times in total
Back to top
View user's profile Send private message Send e-mail Visit poster's website
simo
Owner


Joined: 22 Mar 2015
Posts: 646

PostPosted: Sat Mar 27, 2021 6:22 pm    Post subject: Reply with quote

it looks like i didnt create the API key properly
Back to top
View user's profile Send private message
ComputerTech
Master


Joined: 22 Feb 2020
Posts: 374

PostPosted: Sat Mar 27, 2021 6:23 pm    Post subject: Reply with quote

You can try test your API and Engine ID wih the following URL

Code:

"https://www.googleapis.com/customsearch/v1?key=YOUR-API-KEY-HERE&cx=YOUR-ENGINE-ID-HERE&q=SEARCH-TERM"



If it results to a page with a error, paste here that whole error and surroundings
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
simo
Owner


Joined: 22 Mar 2015
Posts: 646

PostPosted: Sat Mar 27, 2021 6:35 pm    Post subject: Reply with quote

it seems to work proper now thanks
Back to top
View user's profile Send private message
ComputerTech
Master


Joined: 22 Feb 2020
Posts: 374

PostPosted: Sat Mar 27, 2021 6:53 pm    Post subject: Reply with quote

No Problem simo, glad you got it working
:
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
simo
Owner


Joined: 22 Mar 2015
Posts: 646

PostPosted: Mon Mar 29, 2021 12:07 pm    Post subject: Reply with quote

tested it some more and it doesnt seem to work with UTF8

Quote:

18:08:16 <Simo> .tcl encoding system
18:08:16 <Falcon> Tcl: utf-8


utf encoding is present
Back to top
View user's profile Send private message
Goga
Voice


Joined: 19 Sep 2020
Posts: 35

PostPosted: Tue Mar 30, 2021 3:34 am    Post subject: Reply with quote

Still having Same problem though updated with your given Code.

Code:
[07:33:14] 02G04o08o02g03l04e.tcl v0.3 by ComputerTech Loaded
[07:33:31] Tcl error [goo:gle]: key "searchInformation" not known in dictionary
Back to top
View user's profile Send private message
ComputerTech
Master


Joined: 22 Feb 2020
Posts: 374

PostPosted: Tue Mar 30, 2021 10:08 am    Post subject: Reply with quote

Goga, have you grabbed the API key and Engine ID i described above? This is a Requirement, as the error you just gave, shows thst you haven't


http://forum.egghelp.org/viewtopic.php?p=109672#109672 << instructions

Or if you have successfully retrieved a API Key and a Engine ID, try putting this in your browser.

Code:


https://www.googleapis.com/customsearch/v1?key=YOUR-API-KEY-HERE&cx=YOUR-ENGINE-ID-HERE&q=SEARCH-TERM


replace accordingly
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Goga
Voice


Joined: 19 Sep 2020
Posts: 35

PostPosted: Wed Mar 31, 2021 2:07 am    Post subject: Reply with quote

You were right, I didn't enable the API Key, Now its working sufficiently,
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Scripting Help All times are GMT - 4 Hours
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber