egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

CT-Google.tcl
Goto page Previous  1, 2
 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Support & Releases
View previous topic :: View next topic  
Author Message
Dominatez
Halfop


Joined: 14 Jan 2019
Posts: 46
Location: United Kingdom

PostPosted: Wed Feb 09, 2022 3:51 pm    Post subject: Reply with quote

Code:

.tcl package require http
Tcl: 2.10a1
.tcl package require json
Tcl: 1.3.3
.tcl package require tls
Tcl: 1.7.20
Back to top
View user's profile Send private message
ComputerTech
Master


Joined: 22 Feb 2020
Posts: 393

PostPosted: Wed Feb 09, 2022 4:17 pm    Post subject: Reply with quote

Well your package versions are slightly older than mine, but i really doubt that would be the cause of this problem. Laughing

This problem only happens when the variable is set to 5 correct? Plus did you try search another term? perhaps like "LEGO" for example, or something more popular perhaps.
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Dominatez
Halfop


Joined: 14 Jan 2019
Posts: 46
Location: United Kingdom

PostPosted: Wed Feb 09, 2022 5:08 pm    Post subject: Reply with quote

Hi,

Tried Searching Lego or anything at all, and it throws that error. 4 and below is fine.
Back to top
View user's profile Send private message
ComputerTech
Master


Joined: 22 Feb 2020
Posts: 393

PostPosted: Wed Feb 09, 2022 5:12 pm    Post subject: Reply with quote

Weird, as it's working just fine for me, i'll get another server of mine and try install the packages the same version that you have and try that. Rolling Eyes
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Dominatez
Halfop


Joined: 14 Jan 2019
Posts: 46
Location: United Kingdom

PostPosted: Wed Feb 09, 2022 5:36 pm    Post subject: Reply with quote

If it helps. It is running on my own personal sever which is running

Ubuntu 20.04.03 LTS Focal
TCL Version 8.6
Back to top
View user's profile Send private message
ComputerTech
Master


Joined: 22 Feb 2020
Posts: 393

PostPosted: Thu Feb 10, 2022 11:57 am    Post subject: Reply with quote

Yeah, i'm running Ubuntu 20.04 too, so that isn't the problem in my opinion, haven't had time yet to run another eggdrop on another server just yet, but i'll try make some time later. Razz
_________________
ComputerTech
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Dominatez
Halfop


Joined: 14 Jan 2019
Posts: 46
Location: United Kingdom

PostPosted: Fri Feb 11, 2022 3:12 pm    Post subject: Reply with quote

Thanks ComputerTech for taking the time.
Back to top
View user's profile Send private message
Goga
Halfop


Joined: 19 Sep 2020
Posts: 75

PostPosted: Sat Feb 12, 2022 5:56 am    Post subject: Reply with quote

Code:
[09:53:48] Tcl error in file 'eggdrop.conf':
 [09:53:48] can't read "::google": no such variable
     while executing
 "putlog "$::google.tcl v0.3 by ComputerTech Loaded""
     (file "scripts/search.tcl" line 116)
     invoked from within
 "source scripts/search.tcl"
     (file "eggdrop.conf" line 210)
 [09:53:48] * CONFIG FILE NOT LOADED (NOT FOUND, OR ERROR)

Help Please...
Back to top
View user's profile Send private message
Dominatez
Halfop


Joined: 14 Jan 2019
Posts: 46
Location: United Kingdom

PostPosted: Sat Feb 12, 2022 6:56 pm    Post subject: Reply with quote

Have you put the API Key In ?

And have you put in the Engine ID key in ?
Back to top
View user's profile Send private message
CrazyCat
Owner


Joined: 13 Jan 2002
Posts: 972
Location: France

PostPosted: Sun Feb 13, 2022 5:33 am    Post subject: Reply with quote

There is an error in the last line of the script:
Code:
putlog "$::google.tcl v0.3 by ComputerTech Loaded"


Must be:
Code:
putlog "CT-google.tcl v0.3 by ComputerTech Loaded"

_________________
https://www.eggdrop.fr
Offer me a coffee - Do not ask me help in PM, we are a community.
Back to top
View user's profile Send private message Visit poster's website
Goga
Halfop


Joined: 19 Sep 2020
Posts: 75

PostPosted: Mon Feb 14, 2022 12:45 am    Post subject: Reply with quote

You are always Right, CrazyCat Smile
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Support & Releases All times are GMT - 4 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber