egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

netbots netupdate error

 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Support & Releases
View previous topic :: View next topic  
Author Message
Ofloo
Owner


Joined: 13 May 2003
Posts: 953
Location: Belguim

PostPosted: Thu Apr 08, 2004 11:55 pm    Post subject: netbots netupdate error Reply with quote

Quote:
[05:52] <Azazel> [05:52] Tcl error [nb_gotcmd]: unmatched open brace in list


i get this while doing this

[05:52] <Ofloo> .netupdate -file scripts/chancmd.tcl
[05:52] <Lucifer> [05:50] #Ofloo# netupdate -file scripts/chancmd.tcl
[05:52] <Lucifer> Initiating transfer of scripts/chancmd.tcl to netbots..
_________________
XplaiN but think of me as stupid
Back to top
View user's profile Send private message Visit poster's website
slennox
Owner


Joined: 22 Sep 2001
Posts: 593

PostPosted: Sat Apr 17, 2004 3:40 am    Post subject: Reply with quote

Never got around to fixing that one.

Does it occur every time? If so, perhaps you can e-mail me a copy of chancmd.tcl as you've configured it, and I'll try to reproduce it on my sorry excuse for a botnet Mr. Green
Back to top
View user's profile Send private message Visit poster's website
ertyu
Voice


Joined: 21 Jan 2005
Posts: 2

PostPosted: Fri Jan 21, 2005 6:38 pm    Post subject: Reply with quote

I'm getting the same error doing a basic netupdate -scripts to one particular bot.
Back to top
View user's profile Send private message
Alchera
Revered One


Joined: 11 Aug 2003
Posts: 3344
Location: Ballarat Victoria, Australia

PostPosted: Fri Jan 21, 2005 9:06 pm    Post subject: Reply with quote

This is weird as I use .netupdate on a regular basis (33 bots on the botnet) and have never come across any errors. I must be one of the lucky ones. Laughing
_________________
Add [SOLVED] to the thread title if your issue has been.
Search | FAQ | RTM
Back to top
View user's profile Send private message Visit poster's website
ertyu
Voice


Joined: 21 Jan 2005
Posts: 2

PostPosted: Sun Nov 27, 2005 3:55 am    Post subject: Reply with quote

I poked at this a bit more today.

I dumped the variables around the error in nb_gotcmd, the one bot appears to send corrupted data back:

rnetupdate {send scripts {{netbots/netbots.tcl 2f5a470af8e84cce8aae051f91e2e750} {netbots/botnetop.tcl 63b69fcd6b4e69755ac5f2f872db2f0f} {netbots/chanlimit.tcl be66a38fefd64199bc555fcb34d31ce9} {netbots/mass.tcl f2bae97bdf95be3e6125ff697f5c22f0} {ne!?;?1fkco}*,S>Xst7#EG 0

Its eggdrop 1.6.17 on solaris/sparc with tcl 8.4.1
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Support & Releases All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber